Back to overview
We are currently experiencing some technical difficulties because of which the platform may respond slower than usual
Mar 4, 2026 at 12:42pm UTC
Affected services
Operator and tenant application
SaltoKS Access Control
open-api.zapfloor.com
Meeting room booking page
Hotdesk booking page
Resolved
Jun 22, 2026 at 8:33am UTC
Because of some unforeseen issues, the platform is loading slower than usual. We are currently trying to resolve the issue. Apologies for the inconvenience.
Affected services
Created
Mar 4, 2026 at 12:42pm UTC
Because of some unforeseen issues, the platform is loading slower than usual. We are currently trying to resolve the issue. Apologies for the inconvenience.
Affected services